タグ屋さんの平台

開発した商品のリリースとアナウンスをします。

gemspecのversionまでたどり着かないというお話

先ほど断念したのですが、

mrknさんが書いたキータの内容で、

version.rbを書かなくてもよい風にできるとか。

できれば、余分なファイルを消したいのでそうしたかった。

疑問

・package-nameとはどのフォルダの名前か

・SuperClassは呼ばれていないといけないか

・gemspecを読み込んでいるはずなのに、

versionがno method errorになるのはなぜか

などの疑問があります、疑問に対して親身に受け答えする必要はないですが、

今のところversion.rbを消すことはできなそうです。

Ruby - gem パッケージのバージョン番号は gemspec で定義すれば良い - Qiita [キータ]

http://qiita.com/mrkn/items/706d9f7451b7f83676ae

Copyright © 2007-2017 Takayuki Kamiyama. All Rights Reserved.